User:WikiMaster/The Dingo Ate My Wiki

From PdxWikiWednesday
< User:WikiMaster
Revision as of 22:18, 1 November 2013 by WikiMaster (Talk | contribs) (Login error: Caption; easy steps.)

Jump to: navigation, search
Dingo-ate-me.png

Update.php

After upgrading PortlandWiki to MediaWiki 1.21.2 and attempting to run php update.php, received the following error:

MediaWiki Update: You are using PHP version 5.2.17 but MediaWiki 1.21 needs PHP 5.3.2 or higher.
ABORTING. Check if you have a newer php executable with a different name, such as php5.

The problem wasn't that PortlandWiki was an outdated version of PHP. Instead the the error was created because of previous changes made to PortlandWiki's PHP.ini settings. These customizations involved making changes to the location of the PHP copy PortlandWiki relies on.

This string will invoke the php update command:
/usr/local/php53/bin/php update.php

See original DreamHost post here.

Login error

Log in create account Login Error.png

Login error
PortlandWiki uses cookies to log in users. You have cookies disabled. Please enable them and try again.

On Thursday, June 14, 2012 anyone trying to log into PortlandWiki and two other wikis on the same DreamHost VPS server began receiving the above login error. The error prevented folks with valid accounts from logging in, even though cookies were not disabled.

(This wiki--pdx.wiki.org--is on a DreamHost shared server, and didn't experience the login issue like the others did.)

On Wednesday, October 23rd, 2013 Kotra found this fix: How can I fix the mediawiki error “Wiki uses cookies to log in users. You have cookies disabled. Please enable them and try again.”?

Four easy steps
  1. Open to LocalSettings.php
  2. Go to the bottom of the page, and enter in the following code: session_save_path("tmp");
  3. Next create a directory called tmp in the folder where you have MediaWiki installed.
  4. Done!

As of 10:30, 27 October 2013 (PDT) it has been applied to PortlandWiki and Telecafe Wiki, and appears to be working.

Various help resources:

The fix Kotra found that worked:
Other suggested fixes:

Internal error (The Dingo Ate Wiki Wednesday Skin)

(Internal error on pdx.wiki.org after installing MW 1.18.2.)

Error Date: 11:49, 24 April 2012 (PDT)

 Global default 'PDXWW' is invalid for field skin

Backtrace:

#0 /home/wikiwednesday/pdx.wiki.org/includes/Preferences.php(1221): Preferences::getPreferences(Object(User))
#1 /home/wikiwednesday/pdx.wiki.org/includes/specials/SpecialPreferences.php(69): Preferences::getFormObject(Object(User))
#2 /home/wikiwednesday/pdx.wiki.org/includes/SpecialPageFactory.php(458): SpecialPreferences->execute(NULL)
#3 /home/wikiwednesday/pdx.wiki.org/includes/Wiki.php(240): SpecialPageFactory::executePath(Object(Title), Object(RequestContext))
#4 /home/wikiwednesday/pdx.wiki.org/includes/Wiki.php(640): MediaWiki->performRequest()
#5 /home/wikiwednesday/pdx.wiki.org/includes/Wiki.php(547): MediaWiki->main()
#6 /home/wikiwednesday/pdx.wiki.org/index.php(57): MediaWiki->run()
#7 {main}
RE - The Dingo Ate Wiki Wednesday Skin

Tue, Apr 24, 2012 at 10:05 PM - Kotra Says:

yeah, I think I ran into the same problems when I created the skin the first time. I think I ended up doing the same bad-coder "fix" I did this time: just modify monobook.

So we're using "monobook" as the default now. But it's actually the PDXWW skin, it's just called monobook because monobook has a lot of pointers to and from it that I don't fully comprehend. I backed up the real monobook skin this time, so it may be less confusing next time around.

Probably we'll run into this issue every time we upgrade mediawiki on pdx.wiki.org. But the process is simple: copy all the files in the skins/PDXWW folder to the skins/monobook folder.

LocalSettings.php & MW 1.18.0rc1

## The protocol and server name to use in fully-qualified URLs
// 25 November 2011 -- Dave Myers commenting out. Both variants shown below appear to force URL path to wiki directory (http://organizedpower.org/smw) to automatically redirect back to domain root.
// $wgServer           = "http://organizedpower.org";
// $wgServer           = "http://organizedpower.org/smw";

export / import templates

Copied two versions of the Template:USSFwikiNews using instructions found here:

http://www.mediawiki.org/wiki/Help:Templates#Copying_from_one_wiki_to_another

The MediaWiki instructions recommended UNCHECKING the "include only the current revision" box before exporting the template. Doing so, however, produces a much larger file. An attempt to import that larger file resulted in a browser and/or server timeout error.

To get a smaller file, make sure the "include only the current revision" remains CHECKED. The imported file from the example shown above imported well, although the image had to be uploaded separately.

.htaccess mod_rewrite woes

Summary
Affected Wiki: PortlandWiki

Started noticing issues with page titles containing "/" characters. URLs containing those characters began resolving to a 404 errors. Later, similar errors began affecting articles with titles containing "." and "&" characters.

Articles Affected (Among Others)
Sources Consulted
Fix Applied
Made adjustments to the .htaccess file:
RewriteEngine On

RewriteCond %{REQUEST_URI} ^/.*&.*
RewriteRule ^/?(.*)&(.*)$ /index.php?title=$1\%26$2 [L,NE]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l
RewriteRule ^(.+)$ index.php?title=$1 [L,QSA]

.htaccess Tools

Thumbnail Errors

Automatic thumbnail generation stopped working on this wiki. This addition to LocalSettings.php fixed it:

$wgMaxShellMemory = 202400;

Source: Error creating thumbnail command not found